Back to Home

Celestron Forum Message

Forums: Atm · Astrophotography · Blackholes · Blackholes2 · CCD · Celestron · Domes · Education
Eyepieces · Meade · Misc. · God and Science · SETI · Software · UFO · XEphem
RSS Button

Home | Discussion Forums | Celestron Equipment Discussion | Post
Login

Be the first pioneers to continue the Astronomy Discussions at our new Astronomy meeting place...
The Space and Astronomy Agora
Maybe

Forum List | Follow Ups | Post Message | Back to Thread Topics | In Response To
Posted by Bob Sal on November 26, 2002 12:43:02 UTC

To you the truth, he doesn't use it very much. So I'm not exactly sure where the problem was or how he fixed it. Your not the first person that said that was all he needed to do. But Celestron did have a real attitude. He's not happy with it. Takes forever to assemble. Then he uses it manually, I've never seen him plug it in. There's no goto, but he should still use the hand controll to move it. It's real stiff manually. Hard to handle. I'd like to see it with the motors running. He's looking to sell it. He payed well over $3000 2 1/2 years ago. But these days, who will pay big bucks for a used scope without a goto.
That's it;
BOB SAL

Follow Ups:

Login to Post
Additional Information
Google
 
Web www.astronomy.net
DayNightLine
About Astronomy Net | Advertise on Astronomy Net | Contact & Comments | Privacy Policy
Unless otherwise specified, web site content Copyright 1994-2018 John Huggins All Rights Reserved
Forum posts are Copyright their authors as specified in the heading above the post.
"dbHTML," "AstroGuide," "ASTRONOMY.NET" & "VA.NET"
are trademarks of John Huggins