Back to Home

Celestron Forum Message

Forums: Atm · Astrophotography · Blackholes · Blackholes2 · CCD · Celestron · Domes · Education
Eyepieces · Meade · Misc. · God and Science · SETI · Software · UFO · XEphem
RSS Button

Home | Discussion Forums | Celestron Equipment Discussion | Post
Login

Be the first pioneers to continue the Astronomy Discussions at our new Astronomy meeting place...
The Space and Astronomy Agora
Bad Board On Powerstar 8 And Ultima 11

Forum List | Follow Ups | Post Message | Back to Thread Topics | In Response To
Posted by Tony Boucher on February 16, 2003 22:06:21 UTC

Cold weather can make the boards act up ! Had a similar problem with both my Powerstar 8" and Ultima 11" ! Returned them to Celestron and they were fixed but that was back in 1993 and 1996 in that order !Both scopes were still under warranty . Odd that Celestron doesn't offer info on the matter since they evidently fixed mine ! I have used both scopes in really cold weather since (-20 F) and have not had any problems . In fact my 11" is mounted in an observatory so is exposed constantly !A man named Victor who headed the sales and service department at Celestron helped me out quite a bit when I had the problems . Maybe he could help you if he is still there!Don't recall his last name but it was something like Anesito !

Regards
Tony B

Follow Ups:

    Login to Post
    Additional Information
    Google
     
    Web www.astronomy.net
    DayNightLine
    About Astronomy Net | Advertise on Astronomy Net | Contact & Comments | Privacy Policy
    Unless otherwise specified, web site content Copyright 1994-2019 John Huggins All Rights Reserved
    Forum posts are Copyright their authors as specified in the heading above the post.
    "dbHTML," "AstroGuide," "ASTRONOMY.NET" & "VA.NET"
    are trademarks of John Huggins